Das Skript mt-check.cgi führt eine Überprüfung Ihrer Systemkonfiguration durch und stellt fest, ob alle zum Betrieb von Movable Type erforderlichen Komponenten vorhanden sind.

Systeminformation

Überprüfe Erforderlich-Modue

CGI::Cookie

Auf Ihrem Server ist CGI::Cookie in der Version 1.30 installiert.

LWP::UserAgent

Auf Ihrem Server ist LWP::UserAgent in der Version 5.834 installiert.

File::Spec (version >= 0.8)

Auf Ihrem Server ist File::Spec in der Version 3.3 installiert.

Image::Size

Auf Ihrem Server ist Image::Size in der Version 3.231 installiert.

CGI

Auf Ihrem Server ist CGI in der Version 3.60 installiert.

Überprüfe Datenbank-Modue

Die folgenden Module sind zur Abindung der Datenbank an Movable Type erforderlich. Zur Nutzung des Systems müssen DBI und das Modul für den jeweiligen Datenbank-Typ installiert sein.

DBI (version >= 1.21)

Auf Ihrem Server ist DBI in der Version 1.609 installiert.

DBD::mysql

Auf Ihrem Server ist DBD::mysql in der Version 4.013 installiert.

DBD::SQLite

Auf Ihrem Server ist DBD::SQLite in der Version 1.27 installiert.

DBD::Pg (version >= 1.32)

Auf Ihrem Server ist DBD::Pg in der Version 2.15.1 installiert.

DBD::SQLite2

Auf Ihrem Server ist DBD::SQLite2 in der Version 0.33 installiert.

Überprüfe Optional-Modue

Die folgenden Module sind optional. Sie brauchen zusätzlich nur dann installiert zu werden, wenn Sie die von ihnen bereitgestellten Funktionen nutzen möchten.

Net::SSLeay

Auf Ihrem Server ist Net::SSLeay in der Version 1.35 installiert.

IPC::Run

Auf Ihrem Server ist IPC::Run in der Version 0.84 installiert.

Archive::Zip

Auf Ihrem Server ist Archive::Zip in der Version 1.30 installiert.

Net::SMTP::TLS

Auf Ihrem Server ist Net::SMTP::TLS in der Version 0.12 installiert.

Authen::SASL

Auf Ihrem Server ist Authen::SASL in der Version 2.13 installiert.

Storable

Auf Ihrem Server ist Storable in der Version 2.20 installiert.

List::Util

Auf Ihrem Server ist List::Util in der Version 1.21 installiert.

CGI::PSGI

Dieses Modul und seine Abhängigkeiten sind zum Betrieb von Movable Type unter psgi erforderlich.

Auf Ihrem Server ist CGI::PSGI selbst oder ein von CGI::PSGI erforderliches Modul nicht installiert. Bitte beachten Sie bei der Installation von CGI::PSGI die Installationshinweise. Details

Can't locate CGI/PSGI.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 171) line 1, line 1662. BEGIN failed--compilation aborted at (eval 171) line 1, line 1662.

Cache::Memcached

Auf Ihrem Server ist Cache::Memcached in der Version 1.28 installiert.

Digest::SHA

Auf Ihrem Server ist Digest::SHA in der Version 5.47 installiert.

Cache::File

Cache::File ist zur Authentifizierung von Kommentarautoren per OpenID an Yahoo! Japan erforderlich.

Auf Ihrem Server ist Cache::File selbst oder ein von Cache::File erforderliches Modul nicht installiert. Bitte beachten Sie bei der Installation von Cache::File die Installationshinweise. Details

Can't locate Cache/File.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 222) line 1, line 1662. BEGIN failed--compilation aborted at (eval 222) line 1, line 1662.

Crypt::SSLeay

Auf Ihrem Server ist Crypt::SSLeay in der Version 0.57 installiert.

GD

Auf Ihrem Server ist GD in der Version 2.44 installiert.

Archive::Tar

Auf Ihrem Server ist Archive::Tar in der Version 1.58 installiert.

Safe

Auf Ihrem Server ist Safe in der Version 2.27 installiert.

CGI::Parse::PSGI

Auf Ihrem Server ist CGI::Parse::PSGI in der Version unbekannt installiert.

Image::Magick

Auf Ihrem Server ist Image::Magick in der Version 6.72 installiert.

File::Temp

Auf Ihrem Server ist File::Temp in der Version 0.22 installiert.

HTML::Parser

Auf Ihrem Server ist HTML::Parser in der Version 3.64 installiert.

XML::SAX

Auf Ihrem Server ist XML::SAX in der Version 0.96 installiert.

Scalar::Util

Auf Ihrem Server ist Scalar::Util in der Version 1.21 installiert.

Crypt::DSA

Auf Ihrem Server ist Crypt::DSA in der Version 1.17 installiert.

SOAP::Lite (version >= 0.5)

Auf Ihrem Server ist SOAP::Lite in der Version 0.714 installiert.

Text::Balanced

Auf Ihrem Server ist Text::Balanced in der Version 2.0.0 installiert.

Digest::MD5

Auf Ihrem Server ist Digest::MD5 in der Version 2.39 installiert.

HTML::Entities

Auf Ihrem Server ist HTML::Entities in der Version 3.64 installiert.

XML::Parser

Auf Ihrem Server ist XML::Parser in der Version 2.36 installiert.

IO::Socket::SSL

Auf Ihrem Server ist IO::Socket::SSL in der Version 1.31 installiert.

IO::Uncompress::Gunzip

Auf Ihrem Server ist IO::Uncompress::Gunzip in der Version 2.021 installiert.

Digest::SHA1

Auf Ihrem Server ist Digest::SHA1 in der Version 2.12 installiert.

Plack

Dieses Modul und seine Abhängigkeiten sind zum Betrieb von Movable Type unter psgi erforderlich.

Auf Ihrem Server ist Plack selbst oder ein von Plack erforderliches Modul nicht installiert. Bitte beachten Sie bei der Installation von Plack die Installationshinweise. Details

Can't locate Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 363) line 1. BEGIN failed--compilation aborted at (eval 363) line 1.

Imager

Auf Ihrem Server ist Imager in der Version 0.72 installiert.

IO::Compress::Gzip

Auf Ihrem Server ist IO::Compress::Gzip in der Version 2.021 installiert.

XML::Atom

Auf Ihrem Server ist XML::Atom in der Version 0.38 installiert.

Net::SMTP

Auf Ihrem Server ist Net::SMTP in der Version 2.31 installiert.

MIME::Base64

Auf Ihrem Server ist MIME::Base64 in der Version 3.08 installiert.

XMLRPC::Transport::HTTP::Plack

Dieses Modul und seine Abhängigkeiten sind zum Betrieb von Movable Type unter psgi erforderlich.

Auf Ihrem Server ist XMLRPC::Transport::HTTP::Plack selbst oder ein von XMLRPC::Transport::HTTP::Plack erforderliches Modul nicht installiert. Bitte beachten Sie bei der Installation von XMLRPC::Transport::HTTP::Plack die Installationshinweise. Details

Can't locate XMLRPC/Transport/HTTP/Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 376) line 1. BEGIN failed--compilation aborted at (eval 376) line 1.

Net::SMTP::SSL

Auf Ihrem Server ist Net::SMTP::SSL in der Version 1.01 installiert.

Der Movable Type-Systemcheck war erfolgreich!

Sie können sofort anfangen! Alle erforderlichen Module sind auf Ihrem Server installiert. Beginnen Sie jetzt mit der Installation von Movable Type.