The mt-check.cgi script provides you with information about your system's configuration and determines whether you have all of the components you need to run Movable Type.

System Information

Checking for Required Modules

CGI::Cookie

Your server has CGI::Cookie installed (version 1.30).

LWP::UserAgent

Your server has LWP::UserAgent installed (version 5.834).

File::Spec (version >= 0.8)

Your server has File::Spec installed (version 3.3).

Image::Size

Your server has Image::Size installed (version 3.231).

CGI

Your server has CGI installed (version 3.60).

Checking for Data Storage Modules

The following modules are required by databases that can be used with Movable Type. Your server must have DBI and at least one of these related modules installed for the application to work properly.

DBI (version >= 1.21)

Your server has DBI installed (version 1.609).

DBD::mysql

Your server has DBD::mysql installed (version 4.013).

DBD::SQLite

Your server has DBD::SQLite installed (version 1.27).

DBD::Pg (version >= 1.32)

Your server has DBD::Pg installed (version 2.15.1).

DBD::SQLite2

Your server has DBD::SQLite2 installed (version 0.33).

Checking for Optional Modules

The following modules are optional. If your server does not have these modules installed, you only need to install them if you require the functionality that they provide.

Net::SSLeay

Your server has Net::SSLeay installed (version 1.35).

IPC::Run

Your server has IPC::Run installed (version 0.84).

Archive::Zip

Your server has Archive::Zip installed (version 1.30).

Net::SMTP::TLS

Your server has Net::SMTP::TLS installed (version 0.12).

Authen::SASL

Your server has Authen::SASL installed (version 2.13).

Storable

Your server has Storable installed (version 2.20).

List::Util

Your server has List::Util installed (version 1.21).

CGI::PSGI

This module and its dependencies are required to run Movable Type under psgi.

Your server does not have CGI::PSGI installed, or CGI::PSGI requires another module that is not installed. Please consult the installation instructions for help in installing CGI::PSGI. Details

Can't locate CGI/PSGI.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 170) line 1, line 1662. BEGIN failed--compilation aborted at (eval 170) line 1, line 1662.

Cache::Memcached

Your server has Cache::Memcached installed (version 1.28).

Digest::SHA

Your server has Digest::SHA installed (version 5.47).

Cache::File

Cache::File is required if you would like to be able to allow commenters to be authenticated by Yahoo! Japan as OpenID.

Your server does not have Cache::File installed, or Cache::File requires another module that is not installed. Please consult the installation instructions for help in installing Cache::File. Details

Can't locate Cache/File.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 221) line 1, line 1662. BEGIN failed--compilation aborted at (eval 221) line 1, line 1662.

Crypt::SSLeay

Your server has Crypt::SSLeay installed (version 0.57).

GD

Your server has GD installed (version 2.44).

Archive::Tar

Your server has Archive::Tar installed (version 1.58).

Safe

Your server has Safe installed (version 2.27).

CGI::Parse::PSGI

Your server has CGI::Parse::PSGI installed (version unknown).

Image::Magick

Your server has Image::Magick installed (version 6.72).

File::Temp

Your server has File::Temp installed (version 0.22).

HTML::Parser

Your server has HTML::Parser installed (version 3.64).

XML::SAX

Your server has XML::SAX installed (version 0.96).

Scalar::Util

Your server has Scalar::Util installed (version 1.21).

Crypt::DSA

Your server has Crypt::DSA installed (version 1.17).

SOAP::Lite (version >= 0.5)

Your server has SOAP::Lite installed (version 0.714).

Text::Balanced

Your server has Text::Balanced installed (version 2.0.0).

Digest::MD5

Your server has Digest::MD5 installed (version 2.39).

HTML::Entities

Your server has HTML::Entities installed (version 3.64).

XML::Parser

Your server has XML::Parser installed (version 2.36).

IO::Socket::SSL

Your server has IO::Socket::SSL installed (version 1.31).

IO::Uncompress::Gunzip

Your server has IO::Uncompress::Gunzip installed (version 2.021).

Digest::SHA1

Your server has Digest::SHA1 installed (version 2.12).

Plack

This module and its dependencies are required to run Movable Type under psgi.

Your server does not have Plack installed, or Plack requires another module that is not installed. Please consult the installation instructions for help in installing Plack. Details

Can't locate Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 362) line 1. BEGIN failed--compilation aborted at (eval 362) line 1.

Imager

Your server has Imager installed (version 0.72).

IO::Compress::Gzip

Your server has IO::Compress::Gzip installed (version 2.021).

XML::Atom

Your server has XML::Atom installed (version 0.38).

Net::SMTP

Your server has Net::SMTP installed (version 2.31).

MIME::Base64

Your server has MIME::Base64 installed (version 3.08).

XMLRPC::Transport::HTTP::Plack

This module and its dependencies are required to run Movable Type under psgi.

Your server does not have XMLRPC::Transport::HTTP::Plack installed, or XMLRPC::Transport::HTTP::Plack requires another module that is not installed. Please consult the installation instructions for help in installing XMLRPC::Transport::HTTP::Plack. Details

Can't locate XMLRPC/Transport/HTTP/Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 375) line 1. BEGIN failed--compilation aborted at (eval 375) line 1.

Net::SMTP::SSL

Your server has Net::SMTP::SSL installed (version 1.01).

Movable Type System Check Successful

You're ready to go! Your server has all of the required modules installed; you do not need to perform any additional module installations. Continue with the installation instructions.