El script mt-check.cgi le ofrece información sobre la configuración del sistema y determina si posee todos los componentes necesarios para ejecutar Movable Type.

Información del sistema

Módulos Comprobando Necesario

CGI::Cookie

El servidor tiene CGI::Cookie instalado (versión 1.30).

LWP::UserAgent

El servidor tiene LWP::UserAgent instalado (versión 5.834).

File::Spec (version >= 0.8)

El servidor tiene File::Spec instalado (versión 3.3).

Image::Size

El servidor tiene Image::Size instalado (versión 3.231).

CGI

El servidor tiene CGI instalado (versión 3.60).

Módulos Comprobando Base de datos

Las bases de datos necesitan los siguientes módulos para su uso con Movable Type. Para que funcione correctamente, el servidor debe tener instalado DBI y al menos uno de estos módulos relacionados. The following modules are required by databases that can be used with Movable Type.

DBI (version >= 1.21)

El servidor tiene DBI instalado (versión 1.609).

DBD::mysql

El servidor tiene DBD::mysql instalado (versión 4.013).

DBD::SQLite

El servidor tiene DBD::SQLite instalado (versión 1.27).

DBD::Pg (version >= 1.32)

El servidor tiene DBD::Pg instalado (versión 2.15.1).

DBD::SQLite2

El servidor tiene DBD::SQLite2 instalado (versión 0.33).

Módulos Comprobando Opcional

Los siguientes módulos son opcionales. Si el servidor no tiene estos módulos instalados, sólo deberá instalarlos si necesita la funcionalidad que proporcionan.

Net::SSLeay

El servidor tiene Net::SSLeay instalado (versión 1.35).

IPC::Run

El servidor tiene IPC::Run instalado (versión 0.84).

Archive::Zip

El servidor tiene Archive::Zip instalado (versión 1.30).

Net::SMTP::TLS

El servidor tiene Net::SMTP::TLS instalado (versión 0.12).

Authen::SASL

El servidor tiene Authen::SASL instalado (versión 2.13).

Storable

El servidor tiene Storable instalado (versión 2.20).

List::Util

El servidor tiene List::Util instalado (versión 1.21).

CGI::PSGI

Este módulo y sus dependencias son necesarios para ejecutar Movable Type bajo psgi.

El servidor no tiene CGI::PSGI instalado o CGI::PSGI necesita otro módulo que no está instalado. Por favor, consulte las instrucciones de instalación si quiere ayuda sobre la instalación de CGI::PSGI. Detalles

Can't locate CGI/PSGI.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 171) line 1, line 1662. BEGIN failed--compilation aborted at (eval 171) line 1, line 1662.

Cache::Memcached

El servidor tiene Cache::Memcached instalado (versión 1.28).

Digest::SHA

El servidor tiene Digest::SHA instalado (versión 5.47).

Cache::File

Cache::File es necesario si desea que los comentaristas puedan autentificarse por Yahoo! Japan mediante OpenID.

El servidor no tiene Cache::File instalado o Cache::File necesita otro módulo que no está instalado. Por favor, consulte las instrucciones de instalación si quiere ayuda sobre la instalación de Cache::File. Detalles

Can't locate Cache/File.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 222) line 1, line 1662. BEGIN failed--compilation aborted at (eval 222) line 1, line 1662.

Crypt::SSLeay

El servidor tiene Crypt::SSLeay instalado (versión 0.57).

GD

El servidor tiene GD instalado (versión 2.44).

Archive::Tar

El servidor tiene Archive::Tar instalado (versión 1.58).

Safe

El servidor tiene Safe instalado (versión 2.27).

CGI::Parse::PSGI

El servidor tiene CGI::Parse::PSGI instalado (versión desconocido).

Image::Magick

El servidor tiene Image::Magick instalado (versión 6.72).

File::Temp

El servidor tiene File::Temp instalado (versión 0.22).

HTML::Parser

El servidor tiene HTML::Parser instalado (versión 3.64).

XML::SAX

El servidor tiene XML::SAX instalado (versión 0.96).

Scalar::Util

El servidor tiene Scalar::Util instalado (versión 1.21).

Crypt::DSA

El servidor tiene Crypt::DSA instalado (versión 1.17).

SOAP::Lite (version >= 0.5)

El servidor tiene SOAP::Lite instalado (versión 0.714).

Text::Balanced

El servidor tiene Text::Balanced instalado (versión 2.0.0).

Digest::MD5

El servidor tiene Digest::MD5 instalado (versión 2.39).

HTML::Entities

El servidor tiene HTML::Entities instalado (versión 3.64).

XML::Parser

El servidor tiene XML::Parser instalado (versión 2.36).

IO::Socket::SSL

El servidor tiene IO::Socket::SSL instalado (versión 1.31).

IO::Uncompress::Gunzip

El servidor tiene IO::Uncompress::Gunzip instalado (versión 2.021).

Digest::SHA1

El servidor tiene Digest::SHA1 instalado (versión 2.12).

Plack

Este módulo y sus dependencias son necesarios para ejecutar Movable Type bajo psgi.

El servidor no tiene Plack instalado o Plack necesita otro módulo que no está instalado. Por favor, consulte las instrucciones de instalación si quiere ayuda sobre la instalación de Plack. Detalles

Can't locate Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 363) line 1. BEGIN failed--compilation aborted at (eval 363) line 1.

Imager

El servidor tiene Imager instalado (versión 0.72).

IO::Compress::Gzip

El servidor tiene IO::Compress::Gzip instalado (versión 2.021).

XML::Atom

El servidor tiene XML::Atom instalado (versión 0.38).

Net::SMTP

El servidor tiene Net::SMTP instalado (versión 2.31).

MIME::Base64

El servidor tiene MIME::Base64 instalado (versión 3.08).

XMLRPC::Transport::HTTP::Plack

Este módulo y sus dependencias son necesarios para ejecutar Movable Type bajo psgi.

El servidor no tiene XMLRPC::Transport::HTTP::Plack instalado o XMLRPC::Transport::HTTP::Plack necesita otro módulo que no está instalado. Por favor, consulte las instrucciones de instalación si quiere ayuda sobre la instalación de XMLRPC::Transport::HTTP::Plack. Detalles

Can't locate XMLRPC/Transport/HTTP/Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 376) line 1. BEGIN failed--compilation aborted at (eval 376) line 1.

Net::SMTP::SSL

El servidor tiene Net::SMTP::SSL instalado (versión 1.01).

Comprobación del sistema realizada con éxito

¡Ya está preparado! El servidor tiene todos los módulos necesarios instalados; no tiene que realizar ninguna instalación adicional. Continúe con las instrucciones de instalación.