Le script mt-check.cgi vous fournit des informations sur la configuration de votre système et détermine si vous avez tous les composants nécessaires pour exécuter Movable Type.

Informations système

Vérification des modules nécessaires

CGI::Cookie

Votre serveur possède CGI::Cookie (version 1.30).

LWP::UserAgent

Votre serveur possède LWP::UserAgent (version 5.834).

File::Spec (version >= 0.8)

Votre serveur possède File::Spec (version 3.3).

Image::Size

Votre serveur possède Image::Size (version 3.231).

CGI

Votre serveur possède CGI (version 3.60).

Vérification des modules Stockage des données

Les modules suivants sont requis par les bases de données utilisables par Movable Type. DBI et au moins l'un des modules idoines doivent être installés sur votre serveur pour que l'application fonctionne.

DBI (version >= 1.21)

Votre serveur possède DBI (version 1.609).

DBD::mysql

Votre serveur possède DBD::mysql (version 4.013).

DBD::SQLite

Votre serveur possède DBD::SQLite (version 1.27).

DBD::Pg (version >= 1.32)

Votre serveur possède DBD::Pg (version 2.15.1).

DBD::SQLite2

Votre serveur possède DBD::SQLite2 (version 0.33).

Vérification des modules optionnels

Les modules suivants sont optionnels. Si votre serveur ne dispose pas de ces modules, vous n'avez besoin de les installer que si vous avez besoin de leurs fonctionnalités.

Net::SSLeay

Votre serveur possède Net::SSLeay (version 1.35).

IPC::Run

Votre serveur possède IPC::Run (version 0.84).

Archive::Zip

Votre serveur possède Archive::Zip (version 1.30).

Net::SMTP::TLS

Votre serveur possède Net::SMTP::TLS (version 0.12).

Authen::SASL

Votre serveur possède Authen::SASL (version 2.13).

Storable

Votre serveur possède Storable (version 2.20).

List::Util

Votre serveur possède List::Util (version 1.21).

CGI::PSGI

Ce module et ses dépendances sont nécessaires pour faire fonctionner Movable Type en mode PSGI.

Votre serveur n'a pas CGI::PSGI d'installé ou CGI::PSGI nécessite un autre module qui n'est pas installé. Veuillez consulter les instructions d'installation pour obtenir de l'aide pour installer CGI::PSGI. Détails

Can't locate CGI/PSGI.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 171) line 1, line 1662. BEGIN failed--compilation aborted at (eval 171) line 1, line 1662.

Cache::Memcached

Votre serveur possède Cache::Memcached (version 1.28).

Digest::SHA

Votre serveur possède Digest::SHA (version 5.47).

Cache::File

Cache::File est requis si vous voulez permettre aux auteurs de commentaire l'utilisation de Yahoo! Japon comme moyen d'authentification OpenId.

Votre serveur n'a pas Cache::File d'installé ou Cache::File nécessite un autre module qui n'est pas installé. Veuillez consulter les instructions d'installation pour obtenir de l'aide pour installer Cache::File. Détails

Can't locate Cache/File.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 222) line 1, line 1662. BEGIN failed--compilation aborted at (eval 222) line 1, line 1662.

Crypt::SSLeay

Votre serveur possède Crypt::SSLeay (version 0.57).

GD

Votre serveur possède GD (version 2.44).

Archive::Tar

Votre serveur possède Archive::Tar (version 1.58).

Safe

Votre serveur possède Safe (version 2.27).

CGI::Parse::PSGI

Votre serveur possède CGI::Parse::PSGI (version inconnu).

Image::Magick

Votre serveur possède Image::Magick (version 6.72).

File::Temp

Votre serveur possède File::Temp (version 0.22).

HTML::Parser

Votre serveur possède HTML::Parser (version 3.64).

XML::SAX

Votre serveur possède XML::SAX (version 0.96).

Scalar::Util

Votre serveur possède Scalar::Util (version 1.21).

Crypt::DSA

Votre serveur possède Crypt::DSA (version 1.17).

SOAP::Lite (version >= 0.5)

Votre serveur possède SOAP::Lite (version 0.714).

Text::Balanced

Votre serveur possède Text::Balanced (version 2.0.0).

Digest::MD5

Votre serveur possède Digest::MD5 (version 2.39).

HTML::Entities

Votre serveur possède HTML::Entities (version 3.64).

XML::Parser

Votre serveur possède XML::Parser (version 2.36).

IO::Socket::SSL

Votre serveur possède IO::Socket::SSL (version 1.31).

IO::Uncompress::Gunzip

Votre serveur possède IO::Uncompress::Gunzip (version 2.021).

Digest::SHA1

Votre serveur possède Digest::SHA1 (version 2.12).

Plack

Ce module et ses dépendances sont nécessaires pour faire fonctionner Movable Type en mode PSGI.

Votre serveur n'a pas Plack d'installé ou Plack nécessite un autre module qui n'est pas installé. Veuillez consulter les instructions d'installation pour obtenir de l'aide pour installer Plack. Détails

Can't locate Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 363) line 1. BEGIN failed--compilation aborted at (eval 363) line 1.

Imager

Votre serveur possède Imager (version 0.72).

IO::Compress::Gzip

Votre serveur possède IO::Compress::Gzip (version 2.021).

XML::Atom

Votre serveur possède XML::Atom (version 0.38).

Net::SMTP

Votre serveur possède Net::SMTP (version 2.31).

MIME::Base64

Votre serveur possède MIME::Base64 (version 3.08).

XMLRPC::Transport::HTTP::Plack

Ce module et ses dépendances sont nécessaires pour faire fonctionner Movable Type en mode PSGI.

Votre serveur n'a pas XMLRPC::Transport::HTTP::Plack d'installé ou XMLRPC::Transport::HTTP::Plack nécessite un autre module qui n'est pas installé. Veuillez consulter les instructions d'installation pour obtenir de l'aide pour installer XMLRPC::Transport::HTTP::Plack. Détails

Can't locate XMLRPC/Transport/HTTP/Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 376) line 1. BEGIN failed--compilation aborted at (eval 376) line 1.

Net::SMTP::SSL

Votre serveur possède Net::SMTP::SSL (version 1.01).

Vérification du système Movable Type terminée avec succès.

Vous êtes prêt à continuer ! Votre serveur dispose de tous les modules requis, vous n'avez pas besoin d'installer autre chose. Continuez avec les instructions d'installation.