mt-check.cgiはシステムの構成を確認し、Movable Typeを実行するために必要なコンポーネントがそろっていることを確認するためのスクリプトです。

システム情報

確認中: 必須モジュール

CGI::Cookie

サーバーに CGI::Cookie がインストールされています(バージョン 1.30)。

LWP::UserAgent

サーバーに LWP::UserAgent がインストールされています(バージョン 5.834)。

File::Spec (version >= 0.8)

サーバーに File::Spec がインストールされています(バージョン 3.3)。

Image::Size

サーバーに Image::Size がインストールされています(バージョン 3.231)。

CGI

サーバーに CGI がインストールされています(バージョン 3.60)。

確認中: データストレージモジュール

これらのモジュールは、Movable Type がデータを保存するために必要なモジュールです。DBIと、1つ以上のデータベース用のモジュールをインストールする必要があります。

DBI (version >= 1.21)

サーバーに DBI がインストールされています(バージョン 1.609)。

DBD::mysql

サーバーに DBD::mysql がインストールされています(バージョン 4.013)。

DBD::SQLite

サーバーに DBD::SQLite がインストールされています(バージョン 1.27)。

DBD::Pg (version >= 1.32)

サーバーに DBD::Pg がインストールされています(バージョン 2.15.1)。

DBD::SQLite2

サーバーに DBD::SQLite2 がインストールされています(バージョン 0.33)。

確認中: オプションモジュール

これらのモジュールのインストールは任意です。お使いのサーバーにこれらのモジュールがインストールされていない場合でも、Movable Type の基本機能は動作します。これらのモジュールの機能が必要となった場合にはインストールを行ってください。

Net::SSLeay

サーバーに Net::SSLeay がインストールされています(バージョン 1.35)。

IPC::Run

サーバーに IPC::Run がインストールされています(バージョン 0.84)。

Archive::Zip

サーバーに Archive::Zip がインストールされています(バージョン 1.30)。

Net::SMTP::TLS

サーバーに Net::SMTP::TLS がインストールされています(バージョン 0.12)。

Authen::SASL

サーバーに Authen::SASL がインストールされています(バージョン 2.13)。

Storable

サーバーに Storable がインストールされています(バージョン 2.20)。

List::Util

サーバーに List::Util がインストールされています(バージョン 1.21)。

CGI::PSGI

PSGI環境下でmt.psgiを実行する場合に必要となります。

サーバーに CGI::PSGIか、CGI::PSGIの動作に必要な他のモジュールがインストールされていません。 CGI::PSGIのインストールはインストールマニュアルに沿って行ってください。 詳細

Can't locate CGI/PSGI.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 171) line 1, line 1662. BEGIN failed--compilation aborted at (eval 171) line 1, line 1662.

Cache::Memcached

サーバーに Cache::Memcached がインストールされています(バージョン 1.28)。

Digest::SHA

サーバーに Digest::SHA がインストールされています(バージョン 5.47)。

Cache::File

Yahoo! Japanによるコメント投稿者のOpenID認証を許可する場合に必要となります。

サーバーに Cache::Fileか、Cache::Fileの動作に必要な他のモジュールがインストールされていません。 Cache::Fileのインストールはインストールマニュアルに沿って行ってください。 詳細

Can't locate Cache/File.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 222) line 1, line 1662. BEGIN failed--compilation aborted at (eval 222) line 1, line 1662.

Crypt::SSLeay

サーバーに Crypt::SSLeay がインストールされています(バージョン 0.57)。

GD

サーバーに GD がインストールされています(バージョン 2.44)。

Archive::Tar

サーバーに Archive::Tar がインストールされています(バージョン 1.58)。

Safe

サーバーに Safe がインストールされています(バージョン 2.27)。

CGI::Parse::PSGI

サーバーに CGI::Parse::PSGI がインストールされています(バージョン 不明)。

Image::Magick

サーバーに Image::Magick がインストールされています(バージョン 6.72)。

File::Temp

サーバーに File::Temp がインストールされています(バージョン 0.22)。

HTML::Parser

サーバーに HTML::Parser がインストールされています(バージョン 3.64)。

XML::SAX

サーバーに XML::SAX がインストールされています(バージョン 0.96)。

Scalar::Util

サーバーに Scalar::Util がインストールされています(バージョン 1.21)。

Crypt::DSA

サーバーに Crypt::DSA がインストールされています(バージョン 1.17)。

SOAP::Lite (version >= 0.5)

サーバーに SOAP::Lite がインストールされています(バージョン 0.714)。

Text::Balanced

サーバーに Text::Balanced がインストールされています(バージョン 2.0.0)。

Digest::MD5

サーバーに Digest::MD5 がインストールされています(バージョン 2.39)。

HTML::Entities

サーバーに HTML::Entities がインストールされています(バージョン 3.64)。

XML::Parser

サーバーに XML::Parser がインストールされています(バージョン 2.36)。

IO::Socket::SSL

サーバーに IO::Socket::SSL がインストールされています(バージョン 1.31)。

IO::Uncompress::Gunzip

サーバーに IO::Uncompress::Gunzip がインストールされています(バージョン 2.021)。

Digest::SHA1

サーバーに Digest::SHA1 がインストールされています(バージョン 2.12)。

Plack

PSGI環境下でmt.psgiを実行する場合に必要となります。

サーバーに Plackか、Plackの動作に必要な他のモジュールがインストールされていません。 Plackのインストールはインストールマニュアルに沿って行ってください。 詳細

Can't locate Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 363) line 1. BEGIN failed--compilation aborted at (eval 363) line 1.

Imager

サーバーに Imager がインストールされています(バージョン 0.72)。

IO::Compress::Gzip

サーバーに IO::Compress::Gzip がインストールされています(バージョン 2.021)。

XML::Atom

サーバーに XML::Atom がインストールされています(バージョン 0.38)。

Net::SMTP

サーバーに Net::SMTP がインストールされています(バージョン 2.31)。

MIME::Base64

サーバーに MIME::Base64 がインストールされています(バージョン 3.08)。

XMLRPC::Transport::HTTP::Plack

PSGI環境下でmt.psgiを実行する場合に必要となります。

サーバーに XMLRPC::Transport::HTTP::Plackか、XMLRPC::Transport::HTTP::Plackの動作に必要な他のモジュールがインストールされていません。 XMLRPC::Transport::HTTP::Plackのインストールはインストールマニュアルに沿って行ってください。 詳細

Can't locate XMLRPC/Transport/HTTP/Plack.pm in @INC (@INC contains: plugins/FormattedTextForTinyMCE/lib plugins/StyleCatcher/lib plugins/MultiBlog/lib plugins/TinyMCE/lib plugins/Textile/lib plugins/WidgetManager/lib plugins/spamlookup/lib plugins/WXRImporter/lib plugins/FormattedText/lib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/extlib /virtual/mamk/public_html/main/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 376) line 1. BEGIN failed--compilation aborted at (eval 376) line 1.

Net::SMTP::SSL

サーバーに Net::SMTP::SSL がインストールされています(バージョン 1.01)。

システムのチェックを完了しました。

Movable Typeを利用できます。 お使いのサーバーには、Movable Type の動作に必要なすべてのモジュールがインストールされています。モジュールを追加インストール作業は必要はありません。マニュアルに従い、インストールを続けてください。